Tuesday, April 6, 2010

Old versions of iPhone SDK

You need Apple developer account to login
But Apple has disabled some of the links recently

iPhone SDK 2.2.1 Leopard (10.5.4)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_for_iphone_os_2.2.1__9m2621a__final/iphone_sdk_for_iphone_os_2.2.19m2621afinal.dmg
or here

iPhone SDK 3.0 (Xcode 3.1.3) Leopard (10.5.7)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.0__final/iphone_sdk_3.0__leopard__9m2736__final.dmg


iPhone SDK 3.0 (Xcode 3.2) Snow Leopard (10.6.0)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.0__final/iphone_sdk_3.0__snow_leopard__final.dmg

iPhone SDK 3.1 with Xcode 3.1.4 Leopard (10.5.7)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.1__final/iphone_sdk_3.1_with_xcode_3.1_final__leopard__9m2809.dmg
or here

iPhone SDK 3.1 with XCode 3.2.1 for Snow Leopard (10.6.0)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.1__final/iphone_sdk_3.1_with_xcode_3.2_final__snow_leopard__10a432.dmg

iPhone SDK 3.1.2 with XCode 3.1.4 for Leopard (10.5.7)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.1.2__final/iphone_sdk_3.1.2_with_xcode_3.1.4__leopard__9m2809.dmg

iPhone SDK 3.1.2 with XCode 3.2.1 for Snow Leopard (10.6.0)
http://developer.apple.com/iphone/download.action?path=/iphone/iphone_sdk_3.1.2__final/iphone_sdk_3.1.2_with_xcode_3.2.1__snow_leopard__10m2003.dmg




Update : You are too late, Apple has removed the links above.




iPhone SDK 3.1.3 with XCode 3.1.4 for Leopard (10.5.7)
http://developer.apple.com/ios/download.action?path=/iphone/iphone_sdk_3.1.3__final/iphone_sdk_3.1.3_with_xcode_3.1.4__leopard__9m2809a.dmg

iPhone SDK 3.1.3 with XCode 3.2.1 for Snow Leopard (10.6.0)
http://developer.apple.com/ios/download.action?path=/iphone/iphone_sdk_3.1.3__final/iphone_sdk_3.1.3_with_xcode_3.2.1__snow_leopard__10m2003a.dmg

iPhone SDK 3.2 Final with Xcode 3.2.2 for Snow Leopard (10.6.0)
http://developer.apple.com/ios/download.action?path=/iphone/iphone_sdk_3.2__final/xcode_3.2.2_and_iphone_sdk_3.2_final.dmg

Xcode 3.2.3 and iPhone SDK 4 GM seed for Snow Leopard (10.6.2)
http://developer.apple.com/ios/download.action?path=/iphone/iphone_sdk_4_gm_seed/xcode_3.2.3_and_iphone_sdk_4_gm_seed.dmg

Xcode 3.2.3 and iPhone SDK 4 Final for Snow Leopard (10.6.2)
http://developer.apple.com/ios/download.action?path=/iphone/iphone_sdk_4__final/xcode_3.2.3_and_iphone_sdk_4__final.dmg

Xcode 3.2.3 and iOS SDK 4.0.1 for Snow Leopard (10.6.4)
http://developer.apple.com/ios/download.action?path=/ios/ios_sdk_4.0.1__final/xcode_3.2.3_and_ios_sdk_4.0.1.dmg

Xcode 3.2.3 and iOS SDK 4.0.2 for Snow Leopard (10.6.4)
http://developer.apple.com/ios/download.action?path=/ios/ios_sdk_4.0.2__final/xcode_3.2.3_and_ios_sdk_4.0.2.dmg

Xcode 3.2.4 and iOS SDK 4.1 for Snow Leopard (10.6.4)
http://developer.apple.com/ios/download.action?path=/ios/ios_sdk_4.1__final/xcode_3.2.4_and_ios_sdk_4.1.dmg

Xcode 3.2.5 and iOS SDK 4.2 GM for Snow Leopard (10.6.4)
http://developer.apple.com/ios/download.action?path=/ios/ios_sdk_4.2_gm_seed/xcode_3.2.5_and_ios_sdk_4.2_gm_seed.dmg

Xcode 3.2.5 and iOS SDK 4.2 for Snow Leopard (10.6.4)
http://developer.apple.com/ios/download.action?path=/ios/ios_sdk_4.2__final/xcode_3.2.5_and_ios_sdk_4.2_final.dmg

Xcode 3.2.6 and iOS SDK 4.3 GM Seed for Snow Leopard (10.6.6)
http://developer.apple.com/devcenter/download.action?path=/ios/ios_sdk_4.3_gm_seed/xcode_3.2.6_and_ios_sdk_4.3_gm_seed.dmg

Xcode 3.2.6 and iOS SDK 4.3 for Snow Leopard (10.6.6)
http://adcdownload.apple.com/Developer_Tools/xcode_3.2.6_and_ios_sdk_4.3__final/xcode_3.2.6_and_ios_sdk_4.3__final.dmg

Xcode 3.2.6 and iOS SDK 4.3.1 for Snow Leopard (10.6.6)
http://adcdownload.apple.com/Developer_Tools/xcode_3.2.6_and_ios_sdk_4.3__final/xcode_3.2.6_and_ios_sdk_4.3.dmg

Xcode 4 and iOS SDK 4.3 for Snow Leopard (10.6.6)
http://developer.apple.com/devcenter/download.action?path=/Developer_Tools/xcode_4_and_ios_sdk_4.3__final/xcode_4_and_ios_sdk_4.3__final.dmg


Xcode 4.0.1 and iOS SDK 4.3.1 for Snow Leopard (10.6.6)
http://developer.apple.com/devcenter/download.action?path=/Developer_Tools/xcode_4.0.1_and_ios_sdk_4.3/xcode_4.0.1_and_ios_sdk_4.3.dmg


Xcode 4.0.2 and iOS SDK 4.3.2 for Snow Leopard (10.6.6)
http://developer.apple.com/devcenter/download.action?path=/Developer_Tools/xcode_4.0.2_and_ios_sdk_4.3/xcode_4.0.2_and_ios_sdk_4.3.dmg

Xcode 4.1 for Snow Leopard (10.6.6)
https://developer.apple.com/downloads/download.action?path=Developer_Tools/xcode_4.1_for_snow_leopard_21110/xcode_4.1_for_snow_leopard.dmg

Xcode 4.1 for Lion (10.7)
https://developer.apple.com/downloads/download.action?path=Developer_Tools/xcode_4.1_for_lion/xcode_4.1_for_lion.dmg

Xcode 4.2 and iOS SDK 5.0 for Snow Leopard (10.6.6)
https://developer.apple.com/downloads/download.action?path=Developer_Tools/xcode_4.2_for_snow_leopard/xcode_4.2_for_snow_leopard.dmg

https://developer.apple.com/devcenter/download.action?path=/Developer_Tools/xcode_4.2_with_ios_5_sdk/xcode_4.2_and_ios_5_sdk_for_snow_leopard.dmg

Xcode 4.2 and iOS SDK 5.0 for Lion (10.7)
https://developer.apple.com/downloads/download.action?path=Developer_Tools/xcode_4.2_for_lion_21179/xcode_4.2_for_lion.dmg

http://developer.apple.com/devcenter/download.action?path=/Developer_Tools/xcode_4.2_with_ios_5_sdk/xcode_4.2_and_ios_5_sdk_for_lion.dmg

Xcode 4.2.1 and iOS SDK 5.0 for Lion (10.7)
http://developer.apple.com/downloads/download.action?path=Developer_Tools/xcode_4.2.1_for_lion/xcode_4.2.1_for_lion.dmg

Xcode 4.3 and iOS SDK 5.0 for Lion (10.7.2)
Note: For Xcode 4.3, you need also to install the optional components such as command line tools, and previous iOS Simulators from Xcode’s Download’s preferences
http://adcdownload.apple.com/Developer_Tools/xcode_4.3_for_lion_21266/xcode_43_lion.dmg

Xcode 4.3.1 and iOS SDK 5.1 for Lion (10.7.3)
http://adcdownload.apple.com/Developer_Tools/xcode_4.3.1_for_lion_21267/xcode_431_lion.dmg

Xcode 4.3.2 and iOS SDK 5.1 for Lion (10.7.3)
http://adcdownload.apple.com/Developer_Tools/xcode_4.3.2/xcode_432_lion.dmg

Xcode 4.3.3 and iOS SDK 5.1 for Lion (10.7.3)
http://adcdownload.apple.com/Developer_Tools/xcode_4.3.3_for_lion/xcode_4.3.3_for_lion.dmg

Xcode 4.4 and iOS SDK 5.1 for Lion (10.7.3) or Mountain Lion (10.8)
http://adcdownload.apple.com/Developer_Tools/xcode_4.4_21362/xcode446938108a.dmg

Xcode 4.4.1 and iOS SDK 5.1 for Lion (10.7.3) or Mountain Lion (10.8)
http://adcdownload.apple.com/Developer_Tools/xcode_4.4.1/xcode_4.4.1_6938145.dmg
http://adcdownload.apple.com/Developer_Tools/xcode_4.4.1/command_line_tools_for_xcode_os_x_mountain_lion_aug_2012.dmg

Xcode 4.5 and iOS SDK 6 GM Seed for Lion (10.7.4) and Mountain Lion (10.8)
http://adcdownload.apple.com//Developer_Tools/xcode_4.5_gm_seed/xcode_4.5_gm_seed.dmg

Xcode 4.5 and iOS SDK 6 for Lion (10.7.4) and Mountain Lion (10.8)
http://adcdownload.apple.com/Developer_Tools/xcode_4.5/xcode_4.5.dmg

Command Line Tool for Xcode 4.5 for Mountain Lion (10.8)
http://adcdownload.apple.com/Developer_Tools/command_line_tools_for_xcode_4.5_os_x_mountain_lion__september_2012/command_line_tools_for_xcode_4.5_os_x_mountain_lion.dmg

Command Line Tool for Xcode 4.5 for Lion (10.7.4)
http://adcdownload.apple.com/Developer_Tools/command_line_tools_for_xcode_4.5_os_x_lion__september_2012/command_line_tools_for_xcode_4.5_os_x_lion.dmg


.
.
.

57 comments:

nandoz said...

Thank you!
Nando :-)

Anonymous said...

This was extremely helpful! Didn't want to upgrade my OS just to run the iPhone simulator! The new version of the iPhone SDK requires 10.6.2 and I am on a 10.5.8 box. Thanks again!

John Adams said...

thanks so much - a really big help

Adam Dunn said...

Awesome! I'm running an older (second-hand) Leopard system, and just getting in to iPhone development. Was having problems figuring out how I was going to do it, until this.

Anonymous said...

Hm, seems like Apple disabled the links to the old releases. I just get an "Access Denied" error (I do have an Apple Developer account). Too bad.

javacom said...

Apple disabled the link recently
but you can download them from http://www.iphonefix.de/

praveen said...

Thank you very much.

bluscience said...

thanks a lot. save me a lot of time.

Nar said...

Thank you. This is very useful.

sullste said...

YOU GUYS ROCK!!! Thank you soooooo much!!!

Ryan said...

Thankx m8,i had 10.5.7 which updated to 10.5.8 and my computer wouldnt urgrade to 10.6.the disk went back and i stuck with 10.5.8,havent downloaded yet as dont have much time but will and hope it works,thanx

ronnie said...

Great, I couldn't find direct links on the apple site. Thanks!

Anonymous said...

Thank you sir.

Sid said...

Sweet! This is awesome work! :D Had been struggling to get the iPHONE SDK working with my Leopard 10.5.6. :)

Anonymous said...

Thanks

7eeso said...

many thanks, i had the same problem. installed 10.5.8 but need to get iPhone SDK 3.1.3 working on it.

so, i downloaded this link from above:
iPhone SDK 3.1.3 with XCode 3.1.4 for Leopard

but when i installed it, it installs iPhone SDK 3.1.2 only and there was no 3.1.3 with it. is there another method, or there is a missing step i didn't follow?

Anonymous said...

This is just great, thank you so much.
The 3.1.3 SDK link is still downloadable, but for how long?
I am shocked by Apple's attitude towards developers: when previous versions of the SDK are still downloadable (which is not always the case...), you cannot find them on the website! Apple website will only give you access to the latest releases, which means upgrading to Snow Leopard if you haven't already.
I don't want to have to upgrade to Snow Leopard just to be able to create iPhone apps!
This is really too aggressively commercial.
I am not a cash cow.

Claudio Morgia said...

Hey guy,
you really saved my life ;-)

I just installed the newest XCode 3.2.3 to see that my current setup doesn't work (mixed iPhone/mac project) because of missing sdk and my poor knowledge of xcode :-(

thank you again :-)

Anonymous said...

Thank you!!!!
I wonder why Apple removed the old sdk links. How to develop apps for iPhone OS 3 without the sdk?

[shaking head] Michael

Max said...

Hey, thanks a ton! I did not want to upgrade to Snow Leopard and this was a really big help!

Anonymous said...

Life saver. Thanks.

pritesh said...

thanks..dude.
You save my time..As a contribution you get one click. :)

Anonymous said...

thank you sooooooooooooo much i have been trying to find this 4 years

Anonymous said...

Big Thanks!

Cha said...

Thank you really much.
I am looking for the old SDK since SDK4 release because the old version worked better on my machine and I can't find the way to download it. Until I found you. You are the live saver.

Thank you again.

miniSun said...

Thanks a lot, buddy!

Software Development India said...

Hey, Thanks a lot for your help.

Harjot Singh said...

Thanks buddy, really nice work

Anonymous said...

Thanks for the help

Rohan Ramesh said...

I could not get this files Hey please can you let me know how can i download these

Cédric Luthi said...

You can get some old links to work by changing http://developer.apple.com/iphone/... to http://developer.apple.com/ios/...

Do not change anything else.

onno said...

You sir, are my hero of the day!

Anonymous said...

Needed to run apps on the sim that only work on sdk 3.1.x. Huge save. Thank you!

DiamondK said...

You saved the day!! Awesome.

Impinge said...

Its such a nice work. Thanks so much. Its really helpful iPhone iPad Application Development

Brad said...

THANK YOU!!!! You just made my day!!!

Anonymous said...

@Cédric Luthi THANK YOU SOOOO MUCH

dgen said...

THANK YOU!!!!

dgen said...

Been looking for this forever.. now I dont have to upgrade to Snow leopard.. yay!
thanks!

Anonymous said...

Thank you!

Anonymous said...

It was not esay to found a old version of xcode on the site of apple... thanks

Anonymous said...

Yes, this post really helped me A LOT. Thanks. It took me about an hour this morning to find a download for a version of XCode that would work with Leopard (3.1.4). Again, it was because all the links seemed to point to only the latest versions (which need snow leopard). I then spent another hour with that XCode download only to find that it didn't have the iOS SDK with it. I'm now trying your link (iPhone SDK 3.1.3 and XCode 3.1.4). I'm hopeful that it is going to work :-)

Thank you for your effort putting this information together for us. It is very appreciated.

Anonymous said...

I was looking around for old versions for last whole week. I could only manage to grab Leopard, that limited me to very few things.

Thanks.

Anonymous said...

Thanks! Very helpful!

Anonymous said...

Thanks so much. You made my day.

Mohamed said...

Hi guys I need your help
can any one help me find this file because I am on a project that needs it but I cant find it anywhere
file name:
iPhone SDK 3.1.2 with XCode 3.1.4 for Leopard

Khang Vo said...

Really great job. I used your post for many times in my iphone development life whenever I need to change my machine, or I need to add some new employee into my iphone team

Anonymous said...

Thanks mate, really appreciate!

speakus.net said...

please correct description:
Xcode 3.2.4 and iOS SDK 4.1 for Snow Leopard (10.6.2)

Anonymous said...

hey dudes, anyone has md5 hash for

iphone_sdk_3.1.3_with_xcode_3.1.4__leopard__9m2809a.dmg

and

xcode_3.2.2_and_iphone_sdk_3.2_final.dmg

I installed the first one a couple month ago but now I upgraded to snow leopard (clean installed, rather) and couldn't install it again, I am downloading the second one now

muthuparavakkal said...

Please give me a xcode iphone SDK link for iOS 10.5.6

Anonymous said...

hi. i got latest lion with Xcode from apple dev web by. new to iPhone dev. do i still need to install iPhone sdk?

noaddress said...

good work!!!
thank you

Anonymous said...

Thank you !!! it is realy helpfull

Anonymous said...

Vlws

Anonymous said...

Has someone still a copy of the iPhone SDK 2.2.1 Leopard (10.5.4):
"iphone_sdk_for_iphone_os_2.2.19m2621afinal.dmg" ?

I need that file but Apple doesn't want to download the file from their servers.
Could someone provide me a copy of it?

send me an email to "Kitchen2010 (AT) web DOT de"

Many thanks in advance !

javacom said...

I have iphone_sdk_for_iphone_os_2.2.19m2621afinal.dmg